Jump to content


Photo
- - - - -

How do I fix component layers?


  • Please log in to reply
9 replies to this topic

#1 kbrunco

kbrunco

    Apprentice Poster

  • Members
  • Pip
  • 30 posts
  • LocationBakersfield, CA

Posted 22 July 2013 - 07:30 PM

Guys I need some help.  I am trying to design a double dresser in Sketchup 8 (still a work in progress and still making design changes).  I tried adding multiple layers and then constructing each piece of the furniture on different layers (aka left side, right side, drawer 1, drawer face 1, etc.).  For some reason when I hide varying layers some of the pieces that are not associated (or should not be associated) with that layer are also hidden.  I check the component info and it claims that it is its own piece on its own layer.  I tried the plug in cutlist just to get a rough idea of how much lumber I need to find and when I try to select own component to be this wood or that wood multiple pieces change to that type of construction material (it goes back to being associated with other layers I believe).  How do I fix this problem to make sure that each component is truly on its own layer? The model is too big to attach so you can see what I am talking about, but would be glad to email it if that will help someone trouble shoot.  The problem is even affecting stuff that I built way off to the side of the model space to make sure nothing was touching so it didn't "magically" merge to other layers.  But when I moved it to the final model it seems to have adopted the neighbors way of thinking.  Please let me know of good ways to fix this (I really really really don't want to have to start over on the project).

 

Thanks,

 

Quin



#2 Chris H

Chris H

    Journeyman Poster

  • Members
  • PipPip
  • 391 posts
  • LocationHartford WI

Posted 23 July 2013 - 05:27 AM

I don't have a lot of experience with layers, but I have found that I need to make each "Board" it's own group or component.  If you do that, Cutlist seems to work well.  



#3 kbrunco

kbrunco

    Apprentice Poster

  • Members
  • Pip
  • 30 posts
  • LocationBakersfield, CA

Posted 23 July 2013 - 05:47 PM

I did that.  I even did it on the respective layer, but for some reason it has decided to link all the layers together.



#4 Byrdie

Byrdie

    Master Poster

  • Members
  • PipPipPip
  • 1,051 posts
  • LocationCambridge, MN

Posted 24 July 2013 - 06:09 PM

Make a copy of your original and try this because I'm not 100% sure - after you add a component to a layer, delete if from any other layers on which you don't want it to appear.  Not sure where I remember that from and I don't play much with layers myself so I'm not confident of that answer.



#5 TerryMcK

TerryMcK

    Master Poster

  • Members
  • PipPipPip
  • 1,431 posts
  • LocationEllesmere Pk, England, UK

Posted 25 July 2013 - 02:32 AM

You need to make sure that the individual entities that make up each respective component are on the same layer as the component.

To do this select a component and have a look at the attributes of it using the Entity Info dialog. Then double click the component to expose all the individual entities. Select all those entities and you may see that the layers property displays a blank pic1.png . This means that the entities are on different layers. If there is only one layer shown you need to change it to the same layer as the component.

Simply click the pulldown and then choose the layer that is the same as the layer that the component is on.

pic2.png  

 

If you make a scene for each layer (making sure you switch off the layers you want hidden before you save/update the scene) you can click the tabs at the top of the picture to enable you to simply switch between layers.



#6 Aaron Marshall

Aaron Marshall

    Journeyman Poster

  • Mentors
  • 392 posts
  • LocationAtlanta, GA

Posted 25 July 2013 - 07:31 AM

I think Terry is on the right track.  You might have the component on a layer called "Drawers", but the stuff inside the component can be on "Left Side Layer" or some other layer if you're not careful.  It's easier than you might think to do this.

 

Best practice is for each individual line or face to always stay on Layer0, the default layer.  When you bundle this stuff into components, put the component on a separate layer but leave all the "inner stuff" on Layer0.

 

I can take a look at your model if you like.  PM me for an e-mail address.



#7 Bob Lang

Bob Lang

    Apprentice Poster

  • Mentors
  • 42 posts

Posted 25 July 2013 - 08:39 AM

What are you trying to accomplish with all of this? Layers in SketchUp don't always function like one whould expect, especially if you are used to using layers in AutoCAD or some other graphics program. If you're using Scenes along with the Layers this can also induce problems as the active layer will change when you move from one scene to another. As Aaron suggests,  keep all the geometry on Layer 0. After you combine things into components, it's safe to move the component to a different layer. It's entirely possible to have geometry within a component on a different layer than the component and that just makes things weird when you turn layers on and off in individual scenes. If all the loose geometry is on Layer0 and you put a component on another layer, the geometry within the component still lives on Layer0.

 

As far as fixing the mess you have, I would go through and delete all the layers except for layer0. As you do this, SketchUp should ask you what you want to do with the geometry on that layer, and givie you the option of deleting it or moving it to the active layer. That will get everything back to Layer0, but you may still need to get rid of extra stuff.

 

If you want different parts to show in some scenes but not others, you don't need to use layers. You can hide components (or other objects) in individual scenes. Right-click on something to "hide" it. When you update the scene, hidden geometry is one of the properties that goes with the scene. If you need to "unhide", select hidden geometry from the view menu. The stuff that is hiding will show as a mesh and you can right-click over the mesh and unhide.

 

When I worked in AutoCAD, layers was the primary method to control the visibility of stuff. Now in SketchUp, about the only time I use layers is for dimensions associated with individual scenes. Make anything that would be a piece of wood in real life a component as soon as you can, so you don't have to worry about things touching and getting stuck. Make a good model of the entire piece before you worry about the appearance of different views. At that point, save a copy of the model and experiment with using scenes to see certain views. You have unlimited space in SketchUp and materials are free. If you want a detailed view of one component, you can park a copy of that component out in empty space.



#8 kbrunco

kbrunco

    Apprentice Poster

  • Members
  • Pip
  • 30 posts
  • LocationBakersfield, CA

Posted 26 July 2013 - 10:59 PM

The advice by Terry seems to be working; it is long and tedious though.  It started to go much faster when I started deleting layers and forcing things to move to a specific layer or just deleted entirely.

 

What I am trying to accomplish is to design a double dresser.  I am very much a beginner and just learning how to work with wood and Sketchup.  I am not familiar with the scenes option of Sketchup, and layers seems to be adequate for the time being (first go at design).  For future designs should I be using scenes?

 

Thanks for the help with this one guys.

 

Quin


  • TerryMcK likes this

#9 Aaron Marshall

Aaron Marshall

    Journeyman Poster

  • Mentors
  • 392 posts
  • LocationAtlanta, GA

Posted 29 July 2013 - 06:10 AM

Like most software, there are multiple ways to get to the same point in SketchUp.  It kind of depends on your preferences.

 

Think of Scenes as camera snapshots.  If there is a particular view you want to keep returning to, you'd create a scene for convenience so you don't have to keep manually zooming and hiding unwanted components.  It's really handy for creating models for other people too, and you can easily print all your scenes.  If you are going to be the only person using the model, and you're comfortable zooming out and panning around to see the view you need at the moment, you don't need to use scenes at all.  They are just a convenient way to "bookmark" a view.

 

Among other things, Scenes keep track of which layers are visible and which objects are hidden.  To make something invisible, you can either hide it or turn off the layer that it's on.  Bob prefers to use the hide method, and I prefer to use layers instead.  There is a complicated reason I prefer layers (see this

http://www.woodtalko...hidden-objects/), but most people won't notice the difference.



#10 Bob Lang

Bob Lang

    Apprentice Poster

  • Mentors
  • 42 posts

Posted 29 July 2013 - 08:49 AM

If you're new to SketchUp, I would suggest concentrating on building an accurate model before you begin to worry about how to present or print it. I try to solve that problem first. If you make everything a component, you can make a copy of that out in space somewhere, make your changes and the parts in the main model that have that same component name will also change. You can also copy the entire model and park it off to the side somewhere and get rid of parts you don't want to see.

For what it's worth, I don't add scenes or layers until I'm finished with the model, but I do make copies all over the place to resolve design issues or make changes.


  • Aaron Marshall likes this





Support the forum by shopping with our affiliates!

Shop Woodworking | Rockler Woodworking & Hardware | Amazon.com

bellforest200x200-tww10 Image Map EagleAmericaCPT 200x200 Ad v4pre