Chris H

Scene's not saving hidden objects

Recommended Posts

I am trying to create dimensions and print screens in Sketchup.

 

When I save my scene and then try to flip between them, it seems to save the camera angle, but not which groups I shown/hidden.  

 

I am sure I have a setting wrong, but I cannot figure out which one.  

 

Thanks for your help.

 

 

-Chris

 

Dining Table V03.skp

Share this post


Link to post
Share on other sites

Just in case anyone else has this issue, it was related to nesting.

 

I had groups within groups, and that seems to have upset SketchUp.  

 

Once I pulled all the groups of groups out, it is working perfect.

Share this post


Link to post
Share on other sites

You've figured it out, but I'll confirm that this is one of SketchUp's quirks.  When you set up a scene, SketchUp only tracks the "highest level" of hidden geometry.  So if you have any nested components or groups, you typically have to manage these manually.  For this reason, actually hiding stuff is a pain to manage.  I've seen models where stuff is hidden and nested, and it actually gets lost because the "unhide" command only works when you are editing the correct group or component where the stuff was originally hidden.

 

Here's a better method though: Use layers. You can put sub-components or groups on a different layer, and turn the layer on and off.  The scene manager will track which layer is on and off, so this will do what you want. For example, you might have a component called "Desk" that contains sub-components called "Top", "Drawer Box" and "Leg".  Within the top level "Desk" you can put each component on different layers. If you want to hide the drawers for a scene, put them on a layer called "Drawer Layer" and turn off the layer, leaving the rest of the desk visible.

 

The layers can be very powerful, but can also be a little confusing.  Things can be on more than one layer, sort of.  You could have the top-level component on the "Desk Layer", and a sub-component on the "Drawer Layer".  So turning off either one of those layers makes the drawers disappear.  But the advantage is that as long as all the layers in the model are turned on, you know everything is visible.  These days I only use the "hide" function to get something out of the way temporarily while I edit something else in that area.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Who's Online   1 Member, 0 Anonymous, 143 Guests (See full list)

  • Forum Statistics

    28610
    Total Topics
    385993
    Total Posts
  • Member Statistics

    21616
    Total Members
    1529
    Most Online
    Andy71
    Newest Member
    Andy71
    Joined